关于Apache Shiro身份验证绕过漏洞(CVE-2020-17510)的预警提示
发布人:xjzx  发布时间:2020-11-18   浏览次数:10

一、漏洞详情

 

Apache ShiroApache软件基金会的一套用于执行认证、授权、加密和会话管理的Java安全框架。

 

Apache Shiro 1.7.0之前版本与Spring结合使用时存在身份验证绕过漏洞,攻击者通过精心构造特殊的HTTP请求来绕过身份验证,从而获取应用程序的访问权限。

 

二、影响范围

 

Apache Shiro <1.7.0

 

三、修复建议

 

Apache官方已发布修复版本,建议受影响用户更新到1.7.0或以上版本。